A fix has been implemented and we are monitoring the results.
Posted May 22, 2026 - 16:55 GMT+08:00
Update
We are continuing to work on a fix for this issue.
Posted May 22, 2026 - 16:29 GMT+08:00
Identified
Unfortunately, we are seeing a resurgence of errors causing unavailability of login and dashboard services. We are working actively to stabilize the platform.
Posted May 22, 2026 - 16:19 GMT+08:00
Monitoring
Service health has been restored and we are monitoring the situation.
Posted May 22, 2026 - 12:39 GMT+08:00
Identified
We are experiencing an issue with account login and are working closely to resolve it. Please be assured that your investments remain secure and unaffected.