History

Resolved
March 8 7:21 PM +08

We've made changes to our systems to address the performance issues. We have been monitoring our systems for the past several hours since the changes were made and we haven't seen any new degradation in performance. We feel confident that this issue is now resolved. Once again, we apologize for this incident.

Monitoring
March 8 9:41 AM +08

We are experiencing performance degradation with our Web and Mobile applications. Customers may notice slower load times or lag. We understand the importance of smooth service operation and apologise for any inconvenience this may cause. Updates will be provided as they become available.

Monitoring
March 6 6:46 PM +08

The loading issues affecting our Web and Mobile applications have been successfully resolved as of 6:43pm SGT.

Identified
March 6 6:32 PM +08

We are currently experiencing loading issues with both our Web and Mobile applications. Users may encounter delays or errors when loading our dashboard. Our engineering team is aware of the issue and is working diligently to resolve it as quickly as possible.