History

Resolved
December 1, 2023 5:00 PM +08

Our monitoring indicates that the service is now healthy. Customers should not have any issue viewing their monthly statements. If you continue to experience issues, please reach out to us via our support channels.
Once again, we apologize for this service disruption.

Monitoring
November 30, 2023 4:33 PM +08

We have deployed a change that has restored access to monthly statements page for customers. We are continuing to monitor the health of the services.

Investigating
November 30, 2023 10:49 AM +08

We are investigating an issue in our monthly statements generation process. Customers will be unable to view their statements while investigations are ongoing. We apologize for this inconvenience and are actively working to restore service.