History

Resolved
March 13 6:27 PM +08

The dashboard loading issues on web and mobile have been fixed. All systems are back to normal. Thank you for your patience.

Investigating
March 13 6:08 PM +08

We're experiencing a partial outage affecting dashboard loading on web and mobile apps. Our team is aware of the issue and is actively working to resolve it as quickly as possible. We apologize for any inconvenience and appreciate your patience.