History

Resolved
April 5 12:43 PM +08

All services have been restored as of now. The issue was identified and resolved by rolling back a recent update. We appreciate your patience and apologize for any inconvenience caused.

Identified
April 5 12:39 PM +08

We are currently experiencing unexpected downtime across all our services.

Our engineering team is actively working to resolve the issue as quickly as possible. Apologies for the inconvenience.