History

Resolved
April 24 1:12 PM +08

Our deposit flows continue to operate normally since the last status update. At this point, we feel confident that this issue is fully resolved. We apologize for any inconvenience this incident may have caused.

Monitoring
April 24 10:24 AM +08

Deposit functionality has been restored across FAST, PayNow and eGIRO channels. We will continue to closely monitor the situation in partnership with our banking services partner.

Investigating
April 24 9:14 AM +08

We have engaged our banking services partner and are actively working with them to restore deposits functionality.

Investigating
April 24 2:05 AM +08

We are investigating issues with cash deposit failures in Singapore. Clients are unable to add new monies to their Endowus account. The failures are across Paynow, FAST & GIRO channels.