History

Resolved
March 21 5:17 PM +08

SMS OTP delivery to M1 subscribers has been fully restored. We apologize for this service disruption.

Monitoring
March 21 1:42 PM +08

We are experiencing SMS OTP delivery delays and failures when sending messages to M1 Network In Singapore. Our SMS delivery service provider is actively engaged in resolving the issue. We apologize for the inconvenience.