History

Resolved
July 17, 2023 6:39 PM +08

We've deployed a change to fix the error. Investment flow is operational now for all clients. We apologize for this brief disruption.

Investigating
July 17, 2023 6:27 PM +08

We are investigating an issue that is blocking some clients from creating investments.